[mtg:Grafdigger's Cage] fails to find any cards (Try it: Grafdigger's Cage). I've double-checked it a few times. I think it's something about the ' in the card name.

(This is very minor) [mtg:Sun Titan] takes you a search page with Sun Titan and Sundering Titan. (Try it: Sun Titan)

I'm not sure whether these are bugs on our part or limitations in the Gatherer interface we're using.

See this question for how this came up.

share
3  
possible duplicate of Can the Magic card auto link feature be improved? – doppelgreener May 16 '15 at 1:12
    
I'm voting to close this as a duplicate of our more recent request on the matter. – doppelgreener May 16 '15 at 1:13
1  
@doppelgreener As the original poster, I'm fine with that. Especially since the other question calls out exactly how to fix it. Plz close as dupe, everyone. – Alex P May 16 '15 at 2:19
    
VTC as duplicate of the newer thread, in which this was resolved. – doppelgreener Jul 5 at 16:10

You'll notice similar problems on the Daily Magic website itself whenever apostrophes are involved. I believe it's something to do with either escaping or straight vs. curled apostrophes.

Edit: If it weren't for the authocard, it would be relatively easy to fix. Sun Titan returns

http://gatherer.wizards.com/Pages/Search/Default.aspx?name=+[sun]+[titan]

If it were

http://gatherer.wizards.com/Pages/Search/Default.aspx?name=+[sun titan]

there would be no problem.

share

My best guesses from messing with Gatherer:

  • [mtg:Grafdigger's Cage] seems to be an issue with Gatherer itself, but it can be worked around on our side by stripping the link text -- basically kill any text between the ' and the next whitespace, so you submit "Grafdigger Cage" to the search script.
  • Circeus has an answer about what to do with [mtg:Sun Titan].

It looks like you can fix the apostrophe issue by just replacing %27 with %20 in the autocard links (and leave any floating characters just the way they are).

E.g. http://www.wizards.com/magic/autocard.asp?name=[Liliana%20s%20Specter]

share

Playing around with the autocard api, it doesn't look like we can fix this.

I'm forced to as the problem is on Wizards end, and I doubt they'll be addressing it. Every time we contact them we don't really get anywhere.

share
5  
It's their bug, but it seems like we can work around it while still respecting their terms and conditions. E.g. change http://www.wizards.com/magic/autocard.asp?name=Grafdigger%27s%20Cage to http://www.wizards.com/magic/autocard.asp?name=[Grafdigger%20Cage] – Alex P May 21 '12 at 20:47
2  
I ran into this today and it was particularly frustrating. To further to cause of getting this fixed, I compiled a list of all cards with an apostrophe or ampersand, with their appropriate multiverse-id, in the following pastebin: pastebin.com/5P6WbPiY Perhaps you could put those in a handy map and, if you get a match on them, link directly to the card instead of to the search page (assuming this isn't against their terms of service). Merry Christmas! :) – corsiKa Dec 24 '12 at 21:17
    
It can easily be fixed using s/'/ /g – ikegami May 6 '15 at 16:54
    
Later down the road we found it wasn't so much a problem with the API, but us using the wrong part of the API. We're closing this as a dupe of the newer question which has the details in an answer. – doppelgreener May 16 '15 at 2:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .